Thursday , 27 October 2016

Basic Configuration required to access Internet through Cisco Router


Basic Configuration required to access Internet through Cisco Router :-

Dear Reader, Today I would like to show you how you can give your entire LAN  internet access through any Cisco Router in only few steps .

Requirement :-

  • Cisco Router
  • Any Layer 2 switch
  • PC
  • Internet via modem or any cable media .

In this example I am going to use as LAN subnet.

Step1 : – Connect your laptop to switch  and give the following IP details on this PC.

IP :

Subnet :

Default Gateway:

Primary DNS :

Secondary DNS:

Step 2: – Connect any port of the switch to your router , however switches has specific port to connect to uplink devices  (so choose the port accordingly ).

Step3:- Now you need to login to your Cisco router , As you going to login to router for the first time so you  need console cable if there is no specific management port there , in case management port are available you can connect  your laptop via LAN cable to that management port and access via any terminal like hyper or SSH or Secure CRT (download now) . generally Cisco uses /24 as Management IP , if this is not available you can scan the live IP via Port Scanner also .

In case of Console , you need to connect your PC to router to console port via console cable . if you don’t have console port on you Laptop then you need a converter called USB to Serial Converter (which normally does not come in Cisco devices package and you need to buy it from outside) . if you have Console port or Converter to connect your laptop then your laptop should have a driver installed called USB to Serial Converter driver , in most of the cases it get automatic installed via the USB converter cable or you should have it handy.

now, you can use any terminal like hyper , SSH or Secure CRT  to open the console connection of the  device.

If you are using USB converter cable to access console then you also need to check the COMM port in device manager that which one gets activated when you connect the cable to any USB port , like COM1 ,COM2, COM3 and so on .

Step4- Finally you are able to login to router . As router has three modes , enable mode , Privilege mode and configuration mode . So, for the very first time you will be logged into enable mode the you can identify this mode via this symbol (>).


Diagram :-

internet Cisco router



here you have to put enable or to get help you can also do ? , like –

CiscoRouter> enable

or ,


now, after writing enable you will go to privilege mode where you can see all the commands and from there only you can go to configuration mode to configure this router . To go to configuration terminal you have to write this command “Configuration terminal” in Privilege mode , like :-

CiscoRouter# Configuration terminal

now, you will be under configuration mode like :-


Step 5 : –  First you need to identify the port , which is connected to switch and which is connected to mode.

Step6:- lets suppose f0/0 is connected to modem and f0/1 is connected to switch then , do the below configuration on f0/1 and f0/0

interface f0/1

ip add

no shut

After configuring port f0/1 you can ping from your PC to router or from router to PC just to check the connectivity . sometime on PC you need to disable local firewall or antivirus or add an exception in the antivirus for ICMP.

interface f0/0

ip add <given by your ISP>

no shut

After configuring port f0/0 , ping the next device which is modem ,  if you are able to ping modem which should be directly connected then configure the default route  as below

ip route  <ip of modem/next-hop>

eg , if modem has ip then route will be

ip route

as you configure the default route on router , you should be able to ping internet from router itself

to check the internet on router  , you can ping any global IP eg: ping or ping

if you get reply means you have internet on router and then proceed ahead to configure NAT as mentioned below :-

  • access-list 100 permit ip any
  •  ip nat inside source list 100 interface f0/0 overload

CiscoRouter(config)# interface fastethernet0/1

CiscoRouter(config-if)# ip nat inside

CiscoRouter(config-if)# interface F 0/0

CiscoRouter(config-if)# ip nat outside R1

and here you go , you should have internet on your PC. if you face any problem feel free to contact us .

Use Facebook to Comment on this Post

About Riyasat Ali

Powered by