Friday , 24 March 2017

How to Configure a Cisco ASA 5510 Firewall – Basic Configuration Tutorial

How to Configure a Cisco ASA 5510 Firewall – Basic Configuration Tutorial ?

In this example , i am going to show you Basic Cisco ASA configuration.

How to Configure a Cisco ASA 5510 Firewall – Basic Configuration Tutorial

 

ciscoasa# configure terminal

ciscoasa(config)# hostname asa

asa(config)# domain-name rumyittips.com

asa(config)# enable password rumyittips

asa(config)# interface ethernet0/0

asa(config-if)# nameif outside

asa(config-if)# security-level 0

asa(config-if)# ip address 192.168.1.1 255.255.255.0

asa(config-if)# no shutdown

asa(config-if)# exit

asa(config)# interface ethernet0/1

asa(config-if)# nameif inside

asa(config-if)# security-level 100

asa(config-if)# ip address 192.168.3.1 255.255.255.0

asa(config-if)# no shutdown

asa(config-if)# exit

asa(config)# interface ethernet0/2

asa(config-if)# nameif dmz

asa(config-if)# security-level 50

asa(config-if)# ip address 192.168.2.1 255.255.255.0

asa(config-if)# no shutdown

asa(config-if)# exit

asa(config)# passwd rumittips

bigdog(config)# crypto key generate rsa

WARNING: You have a RSA keypair already defined named

<Default-RSA-Key>.

Do you really want to replace them? [yes/no]: yes

Keypair generation process begin. Please wait…

asa(config)# ssh 192.168.3.0 255.255.255.0 inside

asa(config)# exit

asa# write memory

Building configuration…
Cryptochecksum: 21657c19 e04a2a24 e502173c 8626e76d
[OK] asa#

The first command that I executed in figure was to change the hostname of
the appliance to asa and a domain name of rumyittips.com. Following this, I configured a Privilege EXEC password of rumyittips.I then configured the three interfaces,
assigning them logical names, security levels, and IP addresses, and enabling them.
Once IP was configured, I wanted to be able to SSH on this appliance, so I assigned
a User EXEC password of rumyittips,generating the public and private RSA keys and
allowing any internal computer SSH access. Finally, I saved the appliance configuration—
remember that you can execute the write memory command at either Privilege EXEC
or Configuration mode.
You will actually need to do quite a few more things to pass traffic through your
appliance, like setting up routing, configuring translation policies (if necessary), setting
up ACLs, and many other policy configurations.

Hope you like my post How to Configure a Cisco ASA 5510 Firewall – Basic Configuration Tutorial. Please Share with others.

For more tips visit my other website www.rumyhacktips.com

Use Facebook to Comment on this Post

About Syed Balal Rumy

A 27 year Tech Geek and a blogger from India ( Bihar ) , live in New Delhi. I am MCITP , CEHv8 , CCNA , CCNA Security , CCNP Security , Security + and CCSA certified. Loves to write tech articles based on my real experiences.

Powered by themekiller.com anime4online.com animextoon.com apk4phone.com